Jump to content


Photo

Auto fire guns.


  • Please log in to reply
14 replies to this topic

#1 Jamosite

Jamosite

    Super-Active Member

  • Donators
  • PipPipPip
  • 203 posts
  • LocationBaltimore Murderland
  • Guild:Gouz / MM / Freelance
  • Server:Andromeda
  • Race:Progen
  • Profession:Warrior

Posted 17 December 2010 - 11:50 AM

Does anyone know of a way you can set your guns "not" to auto fire? if not, is there a way to change this?

I ask because I fly my JD with auto fire off. Each time I log it, it resets back to autofire on.

if it can be done or there is something I am missing please let me know

:->

#2 Shuzun

Shuzun

    Active Member

  • Members
  • PipPip
  • 72 posts
  • Guild:Imperial Guardians
  • Server:Orion
  • Race:Jenquai
  • Profession:Warrior

Posted 17 December 2010 - 04:26 PM

The only way I know is to go to each gun and turn off auto-fire after login :/
Posted Image
Posted Image

#3 Aiel

Aiel

    Active Member

  • Members
  • PipPip
  • 80 posts
  • Server:Andromeda
  • Race:Terran
  • Profession:Trader

Posted 17 December 2010 - 06:06 PM

I've been wondering the same. For now, a simple AC tools macro will do.
ill post it here when I make it if you're interested but it's very simple if you've coded anything at all before

Aiel - JD - 145
Aielpp - PP - 66
Aieltaxi - JE - 57
Aielwar - PW - 18

#4 Marlee

Marlee

    Member

  • Members
  • Pip
  • 22 posts
  • Guild:Colonial Marines
  • Server:Orion
  • Race:Progen
  • Profession:Warrior

Posted 17 December 2010 - 07:56 PM

I thought it would remember if it was on or off after logout. Maybe its a global setting across all characters.

#5 Kyp

Kyp

    Lead Developer - Terran

  • Lead Developers [LDEV]
  • 2941 posts
  • LocationKnoxville, TN USA
  • Guild:Radical Dreamers
  • Server:Andromeda
  • Race:Terran
  • Profession:Warrior

Posted 17 December 2010 - 09:06 PM

Not sure if this would help because I've never had the desire to set up non-auto fire but you can try this:

Go to Game Client Directory\Data\client\output

In here you should find a "shortcut.ini" or shortcut.cfg (don't remember which off the top of my head, sorry.) Remove that file to remove all pre-built shortcuts, and you can set yourself back up as you want with weapons without using the autofire. That might help you out, if not then it simply isn't coded for using single fire only at the moment.

This file is how your shortcut keys are stored.
Kyp
---
Terran Content Lead
Net-7 Entertainment - Board Member
Posted Image
Posted Image
Posted Image
----

Are any of my words making it through to that profit-loving organ, also known as your heart?"


#6 Ghostwing

Ghostwing

    Member

  • Members
  • Pip
  • 31 posts
  • LocationArkansas
  • Guild:Deciples of Rebellion
  • Server:Andromeda
  • Race:Jenquai
  • Profession:Warrior

Posted 18 December 2010 - 06:55 PM

Just press F twice?

#7 Dakynos

Dakynos

    Hyper-Active Member

  • Moderators [MOD]
  • 588 posts
  • Server:Unknown
  • Race:Jenquai
  • Profession:Explorer

Posted 23 December 2010 - 10:40 PM

Also, when you create a new character, auto fire is off by default. Interestingly enough, even if you don't turn it on, when you log out and back in it is magically selected.
Moderator
Earth and Beyond Emulator

Net-7 Entertainment


#8 C Del

C Del

    Technical Support

  • Technical Support [TS]
  • 2328 posts
  • LocationPennsylvania, United States
  • Guild:Search for Intelligent Life
  • Server:Andromeda
  • Race:Progen
  • Profession:Warrior

Posted 23 December 2010 - 10:45 PM

Also, when you create a new character, auto fire is off by default. Interestingly enough, even if you don't turn it on, when you log out and back in it is magically selected.

It is inescapable. There's some other weirdness going on with auto-fire that I intend to take a look at soon as well.
Need help with something? Go to the [url="http://enb-emulator....-support/"]Tech Support Forum[/url] or check the [url="http://enb-emulator....mon-fixes/"]FAQ and Common Fixes[/url].

Posted Image
Posted Image
Posted Image
Posted Image
[url="http://www.tsviewer....926289/CDel.png[/url]

#9 Johnsilver

Johnsilver

    New Member

  • Members
  • 1 posts
  • Server:Andromeda
  • Race:Terran
  • Profession:Warrior

Posted 30 January 2011 - 09:54 AM

Hiya.
I'd like to add a little something here. What we have now in the EMU is not only "AutoFire". We also have
"Autolock on target". The autolock is marked by the little green circle on your wep icons.
This was a pita in Live as your guns kept fireing after targets was dead and in may raids (with lag) it was crusial
to pick right target. Autolock was eventually removed, and an option to activate it was added. like a command,
/Autolock on/off. I realize its confusing.. the autofire thing simply means your guns fire till target is dead.
Autolock locks in on target.. but if your guns are on cooldown and you cycle target the guns will keep on fire.
This is really bad and mark my words will be an issue in future raids when focusing fire is important and a simple cycle can resault in you fire at 5 diffrent mobs couse your guns are acting crasy.
Imo I should Target, then decide on if i should fire.. not target and the guns decide to fire..
pls pls with suga on top remove the autolock.. or add a command to set it on/off.
At least if not possible to remove.. change it so the autolock stops on death of mob.. not next wepon cooldown.

Johnsilver.
Westwood Beta > Sunset with 4 150's

#10 Aiel

Aiel

    Active Member

  • Members
  • PipPip
  • 80 posts
  • Server:Andromeda
  • Race:Terran
  • Profession:Trader

Posted 30 January 2011 - 04:06 PM

Ive had occasional trouble with this too, for example when my beams finish off a target and I switch to the next before they recharge, they are back in auto fire mode. I can press f to turn them back off, but they only stay off for a second and the only way to turn them off so I can cloak and get close without shooting is to untarget and retarget. Hasn't bee a huge deal I see where it could lead to aplenty of trouble in a pressure situation

Aiel - JD - 145
Aielpp - PP - 66
Aieltaxi - JE - 57
Aielwar - PW - 18

#11 Darkk

Darkk

    Super-Active Member

  • Administrators [Admin]
  • 170 posts
  • LocationNew Orleans, LA
  • Guild:Darkk Forces
  • Server:Galileo
  • Race:Jenquai
  • Profession:Warrior

Posted 30 January 2011 - 04:53 PM

Hiya.
I'd like to add a little something here. What we have now in the EMU is not only "AutoFire". We also have
"Autolock on target". The autolock is marked by the little green circle on your wep icons.
This was a pita in Live as your guns kept fireing after targets was dead and in may raids (with lag) it was crusial
to pick right target. Autolock was eventually removed, and an option to activate it was added. like a command,
/Autolock on/off. I realize its confusing.. the autofire thing simply means your guns fire till target is dead.
Autolock locks in on target.. but if your guns are on cooldown and you cycle target the guns will keep on fire.
This is really bad and mark my words will be an issue in future raids when focusing fire is important and a simple cycle can resault in you fire at 5 diffrent mobs couse your guns are acting crasy.
Imo I should Target, then decide on if i should fire.. not target and the guns decide to fire..
pls pls with suga on top remove the autolock.. or add a command to set it on/off.
At least if not possible to remove.. change it so the autolock stops on death of mob.. not next wepon cooldown.

Johnsilver.
Westwood Beta > Sunset with 4 150's


Signed. Definitely an issue.
Forces me to target a group member, and wait for slower guns to reload, so autolock drops. Then I can resume with my next target.
Posted Image

#12 wootage

wootage

    Active Member

  • Donators
  • PipPip
  • 88 posts
  • Server:Galileo
  • Race:Terran
  • Profession:Trader

Posted 30 January 2011 - 08:33 PM

Interesting. I haven't grouped much, and certainly not raided, so I don't know the difficulties there. I will say that for general situations, autolock/autofire combo is very useful - you can simply cycle through targets and your guns will keep on shootin' until everything is dead, at which point you hit the spacebar to stop all guns.

I do encounter two difficulties. One is where when you have selected a single weapon to autofire/not autofire and then used the space bar thinking it will override that selection. But it doesn't, it seems to reverse toggle it. So either there's a weapon not firing when you wanted to fire all, or there's one on autofire waiting for the next target after you've hit the spacebar to stop autofire, and yes I have accidentally shot a friendly something 3x my CL when cycling targets around lol.

(I should clarify, I do not keep the weapons visible on the hotbar, as I have debuffs'n stuff on the alt hotkeys for the weapons. So I can't actually see what's activated/not activated normally. If I manually deselected a weapon to momentarily save reactor power, then flipped the hotbar back to debuff, that's when I encounter the issue - the group leader may go onto the next target, I hit spacebar to activate weapons, start debuffing, then need to manually flip the hotbar back and fix that weapon state).

Edit: I paid more attention to when it happens and it is often triggered by not enough energy to fire all weapons. When a weapon is deactivated by this means, hitting spacebar to toggle them all off instead toggles those back on. This can cost you hull damage repairs if you needed that energy to warp out or recharge shields :)

The second is the autofire command waiting for the next weapon cycle before you can reactivate it, and the "friendly" lock deactivating autofire. I would much prefer it if it could take the command when I give it and hold the activation state for an enemy target. That way I could use the cycle time to do buffs on myself and other group members, then flip back to the target knowing my weapons are all set to go.

Either is not a huge deal as they can be manually overcome, but both seem to show that there's some issues in the way weapon activation interacts with autofire.

#13 Dakynos

Dakynos

    Hyper-Active Member

  • Moderators [MOD]
  • 588 posts
  • Server:Unknown
  • Race:Jenquai
  • Profession:Explorer

Posted 05 February 2011 - 11:36 PM

I'll move this to the suggestion section.

-Moved
Moderator
Earth and Beyond Emulator

Net-7 Entertainment


#14 Rezwalker

Rezwalker

    Active Member

  • Members
  • PipPip
  • 96 posts
  • LocationFlorida
  • Server:Andromeda
  • Race:Jenquai
  • Profession:Explorer

Posted 06 February 2011 - 06:33 AM

I'll move this to the suggestion section.

-Moved


This is a bug and a verry annoying bug at that and needs to go to bugs section not suggestions.

Here's how to reproduce 100% and for those who dont understand the reall issue.
Best way is to use a Jenquai with beams, face away from a mob or even a gate turret works, hit the f key to fire weapons, now hit the f key again to turn them off, a second later they will turn back on by them selfs.
You can't stop them from doing this till you untarget mob.

#15 Orga2

Orga2

    Active Member

  • Members
  • PipPip
  • 75 posts
  • Server:Andromeda
  • Race:Terran
  • Profession:Warrior

Posted 07 February 2011 - 05:16 AM

This is a bug and a verry annoying bug at that and needs to go to bugs section not suggestions.

Here's how to reproduce 100% and for those who dont understand the reall issue.
Best way is to use a Jenquai with beams, face away from a mob or even a gate turret works, hit the f key to fire weapons, now hit the f key again to turn them off, a second later they will turn back on by them selfs.
You can't stop them from doing this till you untarget mob.


I reported this same strange behavior a few months ago... just checking up to see if theres a new thread in the developers bug section or not?

http://forum.enb-emu...-auto-fire-bug/
Posted Image
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users